Selfsigned certifikát pro “www-ssl” na Mikrotiku (RouterOS)

Selfsigned certifikát pro “www-ssl” na Mikrotiku (RouterOS)

Jak si vygenerovat SSL certifikát přímo na routeru.

1) Připojit se na router pomocí SSH

$ ssh UZIVATEL@ADRESAROUTERU [-p PORT]

(Port je potřeba specifikovat jen, pokud ssh na routeru neběží na standardním portu 22)

2) Vygenerování certifikátu vlastní certifikační autority

/certificate
add name=ca-tmpl common-name=OsobniCA key-usage=key-cert-sign,crl-sign
sign ca-tmpl name=OsobníCA

3) Vygenerování SSL certifikátu

/certificate
add name=APcko-tmpl common-name=APcko
sign APcko-tmpl ca=OsobniCA name=APcko

4) Nastavení SSL certifikátu jako trusted

set [find name=APcko] trusted=yes

5) Zapnutí www-ssl služby a nastavení vygenerovaného certifikátů

/ip service set www-ssl certificate=APcko disabled=no

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.